LA CDN Node down for planned maintenance
Incident Report for Nexus Mods
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 11:02 UTC
Investigating
We are upgrading the network card on the LA CDN and it will be down for around an hour whilst we perform this.
Posted Apr 29, 2024 - 07:47 UTC
This incident affected: CDN.