Intermittent website errors

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 15:30 UTC

Investigating

We are investigating issues with user profiles and slow registration / billing pages
Posted Sep 29, 2025 - 14:18 UTC
This incident affected: Nexus Mods Website.