Heavy Traffic
Incident Report for Nexus Mods
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 11:01 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 08:54 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 08:53 UTC
Update
We are still experiencing heavy load on the website and the CDN. We have added more resource to the website and re-routed some file downloads to try and keep things moving.

We continue to monitor the situation.
Posted Apr 21, 2024 - 22:13 UTC
Update
We are aware of impacted performance at the moment and are investigating
Posted Apr 20, 2024 - 14:29 UTC
Investigating
We are experiencing much more traffic than usual due to the popularity of the Fallout TV series. We have deployed extra resources where possible and we are monitoring the uptime and performance across the network. We have staff on call at all times to deal with any problems.

Please do be aware that this extra traffic could cause a degraded experience across the website and our applications.
Posted Apr 19, 2024 - 21:06 UTC
This incident affected: Nexus Mods Website, API, CDN, and Forum.