Planned Maintenance
Incident Report for Nexus Mods
Resolved
Maintenance is now complete and all services are back online.
Posted Apr 03, 2024 - 08:29 UTC
Investigating
Core services offline for essential maintenance

Our website and API are offline for scheduled maintenance. The work began on 3 April 2024 at 08:30 (GMT +1) and is expected to last up to 3 hours.

During this time users will not be able to use the website or any mod manager functionality that depends on our API (this includes downloads).

Join us on Discord ( https://discord.com/invite/nexusmods ) or check back later for updates.

Thank you for your patience!
Posted Apr 03, 2024 - 07:28 UTC
This incident affected: Nexus Mods Website, API, CDN, and Forum.