File & Mod stats unavailable
Incident Report for Nexus Mods
Resolved
These stats are generating correctly again now.
Posted Apr 24, 2024 - 14:07 UTC
Investigating
We are aware of a problem that is currently causing file and download status to be unavailable. This may also effect mod download histories.
Posted Apr 24, 2024 - 11:02 UTC
This incident affected: Nexus Mods Website.