Intermittent website errors
Incident Report for Nexus Mods
Resolved
We have identified an issue with communication inside of our infrastructure and taken steps to resolve it. Work continues in the back ground but currently no services should be affected.
Posted Jan 09, 2025 - 11:07 UTC
Investigating
We're aware that some users are experiencing intermittent website errors, where they are unable to reach the site and only see an error page. An investigation is underway and we hope to find the cause of the issue soon.
Posted Jan 07, 2025 - 07:47 UTC
This incident affected: Nexus Mods Website.