Some customers are experiencing issues with our checkout
Incident Report for Nexus Mods
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 17:07 UTC
Investigating
We're aware of an active incident with our payment provider, which may cause errors with our checkout. The provider is investigating and will hopefully have a resolution as soon as possible.
Posted Jan 13, 2025 - 14:31 UTC
This incident affected: Nexus Mods Website.