We are aware of an incident affecting Forum availability

Incident Report for Nexus Mods

Resolved

Our engineers have identified and resolved the issue and the Forums are operational again.
Thanks for your patience.
Posted Jun 24, 2025 - 02:05 UTC

Investigating

We are currently investigating an outage affecting the forum. Our engineers are working to identify and fix the issue.
Thank you for your patience.
Posted Jun 24, 2025 - 01:47 UTC
This incident affected: Forum.