Issues uploading images and videos blocking mod uploads

Incident Report for Nexus Mods

Resolved

The incident has been resolved.
Posted Apr 28, 2025 - 13:09 UTC

Monitoring

We've identified the problem that has caused this regression. We've implemented a fix and we are monitoring for any further issues.
Posted Apr 28, 2025 - 12:52 UTC

Investigating

We are currently investigating an issue with image and video uploads. This may be stopping new mods from being uploaded.
Posted Apr 28, 2025 - 12:20 UTC
This incident affected: Nexus Mods Website.