Pages unavailable

Incident Report for Nexus Mods

Resolved

The unplanned maintenance is now complete and the site is fully operational.
Posted Jan 22, 2025 - 13:48 UTC

Update

Unplanned maintenance may cause some temporary disruptions.
Posted Jan 22, 2025 - 13:33 UTC

Update

We are conducting some unplanned maintenance to resolve this issue. There may be some further service outages as we make the necessary changes. Thank you for your patience.
Posted Jan 22, 2025 - 13:32 UTC

Monitoring

A fix has been implemented and we are continuing to monitor services and traffic.
Posted Jan 22, 2025 - 13:24 UTC

Identified

We have identified the degraded services and we are currently working on a fix.
Posted Jan 22, 2025 - 13:19 UTC

Investigating

We are aware of issues causing some pages to be unavailable and the team are currently investigating.
Posted Jan 22, 2025 - 13:04 UTC
This incident affected: Nexus Mods Website.