Page not found
Incident Report for
Nexus Mods
Resolved
We have resolved this issue and will monitor for any further issues.
Posted
Jan
29
,
2025
-
13:20
UTC
Update
We are continuing to work on a fix for this issue.
Posted
Jan
29
,
2025
-
12:43
UTC
Identified
We have identified a problem with our infrastructure serving 404 pages for all domains and are attempting to apply a fix.
Posted
Jan
29
,
2025
-
12:37
UTC
Investigating
We are currently investigating page not found errors on the site
Posted
Jan
29
,
2025
-
12:26
UTC
This incident affected: Nexus Mods Website, API, and Forum.
×
Subscribe to Incident
Subscribe to updates for
Page not found
via . You'll receive .