Mod requirement link issue

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted May 06, 2025 - 16:43 UTC

Investigating

We're aware of a bug where the links to mod requirements within a mod page description can become broken after navigating around the page. As a temporary workaround, refreshing the page should resolve the broken links. This issue is under investigation, and the fix is scheduled to be implemented during our working hours. We will provide further updates when a fix has been implemented.
Posted May 03, 2025 - 20:59 UTC
This incident affected: Nexus Mods Website.