Main database issues, website unavailable
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Dec
29
,
2024
-
21:23
UTC
Update
We are continuing to monitor for any further issues.
Posted
Dec
29
,
2024
-
21:11
UTC
Monitoring
The database has been repaired and we are monitoring
Posted
Dec
29
,
2024
-
20:59
UTC
Identified
Our main database is having issues which affects most of the website features. We are looking in to getting it back online ASAP.
Posted
Dec
29
,
2024
-
20:40
UTC
This incident affected: Nexus Mods Website and API.
×
Subscribe to Incident
Subscribe to updates for
Main database issues, website unavailable
via . You'll receive .