Main site not loading
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Sep
10
,
2024
-
15:55
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Sep
10
,
2024
-
10:41
UTC
Update
We are continuing to investigate this issue.
Posted
Sep
10
,
2024
-
10:14
UTC
Investigating
We are investigating intermittent page load errors on the main website
Posted
Sep
10
,
2024
-
09:45
UTC
This incident affected: Nexus Mods Website.
×
Subscribe to Incident
Subscribe to updates for
Main site not loading
via . You'll receive .