Cloudflare outage

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:21 UTC

Monitoring

Services are slowly coming back online
Posted Dec 05, 2025 - 09:15 UTC

Investigating

We are currently investigating this issue.
Posted Dec 05, 2025 - 08:53 UTC
This incident affected: Nexus Mods Website, API, and Forum.