Issue uploading files
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Jan
29
,
2026
-
12:27
UTC
Update
Uploads have resumed - you may still see some delays when uploading files
Thank you for your patience as we continue to work on this issue
Posted
Jan
28
,
2026
-
16:39
UTC
Identified
We have identified an issue with file uploads and we are working to implement a fix
Posted
Jan
28
,
2026
-
13:44
UTC
This incident affected: Nexus Mods Website.
×
Subscribe to Incident
Subscribe to updates for
Issue uploading files
via . You'll receive .