Amsterdam CDN ongoing maintenance

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted 23 days ago. May 20, 2025 - 06:50 UTC

Identified

There is ongoing maintenance taking place between 00:00 and 10:00 UTC+01:00
Posted 23 days ago. May 19, 2025 - 23:41 UTC

Investigating

We are currently investigating this issue.
Posted 23 days ago. May 19, 2025 - 23:28 UTC
This incident affected: CDN.