Upgrades to our infrastructure may cause degradation
Incident Report for Nexus Mods
Resolved
Upgrades have succeeded and we are back to normal operation.
Thank you for your patience.
Posted Apr 25, 2024 - 11:03 UTC
Update
We will have to go offline for this unscheduled maintenance. We apologize for the inconvenience.
Posted Apr 25, 2024 - 09:45 UTC
Identified
We are currently upgrading some components of our infrastructure.
This has a chance to cause some issues or downtime.
Thank you for your patience while we make these changes that will contribute to site upkeep and reliability.
Posted Apr 25, 2024 - 09:44 UTC
This incident affected: Nexus Mods Website, API, CDN, and Forum.