Errors being raised

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted Jan 31, 2025 - 04:13 UTC

Monitoring

We found an issue with our infrastructure and are currently monitoring it.
Posted Jan 31, 2025 - 04:06 UTC

Investigating

We are currently investigating this issue.
Posted Jan 31, 2025 - 03:40 UTC
This incident affected: Nexus Mods Website.