Brief site outage
Incident Report for Nexus Mods
Resolved
This incident has been resolved
Posted Jan 17, 2025 - 07:31 UTC
Investigating
We experienced a brief site outage at 06:53:20 UTC and 06:58:20 and are currently investigating.
Posted Jan 17, 2025 - 07:08 UTC
This incident affected: Nexus Mods Website.