Forums unavailable
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Sep
19
,
2024
-
10:49
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Sep
19
,
2024
-
10:44
UTC
Identified
The issue has been identified and a fix is being implemented.
Posted
Sep
19
,
2024
-
10:41
UTC
Investigating
We are currently investigating this issue.
Posted
Sep
19
,
2024
-
10:31
UTC
This incident affected: Forum.
×
Subscribe to Incident
Subscribe to updates for
Forums unavailable
via . You'll receive .