Platform Outage
Incident Report for Nexus Mods
Resolved
This was a temporary network outage at our cloud provider - all services should be working correctly now.
Posted Jan 09, 2025 - 21:16 UTC
Investigating
We are experiencing an entire platform outage and we are investigating.
Posted Jan 09, 2025 - 20:51 UTC
This incident affected: Nexus Mods Website, API, and Forum.