Forum connection issues

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 11:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2026 - 08:56 UTC

Investigating

We are currently investigating connection issues relating to forums.nexusmods.com. We'll endeavour to get this fixed as soon as possible.
Posted Jan 08, 2026 - 03:46 UTC
This incident affected: Forum.