We are seeing traffic restored from the St Louis datacenter. We will continue monitoring
Posted Jun 18, 2025 - 01:09 UTC
Investigating
We are aware of a networking issue affecting some users in the US - specifically around Missouri. We are investigating the issue and are working with our suppliers to resolve this.
Posted Jun 17, 2025 - 20:25 UTC
This incident affected: Nexus Mods Website, API, CDN, and Forum.