File upload issues
Incident Report for
Nexus Mods
Resolved
Uploads is now working normally. Additionally, we were able to retroactively fix the affected uploads.
Posted
Dec
04
,
2024
-
14:00
UTC
Investigating
We are aware of an issue where uploads are not getting processed properly in many cases.
Our engineering team is currently investigating.
Posted
Dec
04
,
2024
-
08:04
UTC
This incident affected: Nexus Mods Website.
×
Subscribe to Incident
Subscribe to updates for
File upload issues
via . You'll receive .