Site Maintenance
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Nov
11
,
2024
-
13:11
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
11
,
2024
-
12:16
UTC
Identified
The issue has been identified and a fix is being implemented.
Posted
Nov
11
,
2024
-
11:15
UTC
Update
We're aware of connectivity issues to the site. We're currently investigating.
Posted
Nov
11
,
2024
-
10:25
UTC
Investigating
We have scheduled some maintenance for today.
Posted
Nov
11
,
2024
-
09:41
UTC
This incident affected: Nexus Mods Website, API, CDN, and Forum.
×
Subscribe to Incident
Subscribe to updates for
Site Maintenance
via . You'll receive .