Error page when downloading mods
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Jan
31
,
2025
-
16:29
UTC
Update
We are continuing to monitor for any further issues.
Posted
Jan
31
,
2025
-
15:38
UTC
Monitoring
We found an issue with a CDN and have implemented a fix. We are now monitoring for further issues
Posted
Jan
31
,
2025
-
15:38
UTC
Investigating
We are investigating an issue where some users get a 503 error when downloading mods
Posted
Jan
31
,
2025
-
15:18
UTC
This incident affected: Nexus Mods Website.
×
Subscribe to Incident
Subscribe to updates for
Error page when downloading mods
via . You'll receive .