Planned Maintenance
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
May
02
,
2024
-
16:44
UTC
Identified
The site will be down for a few minutes whilst we prepare for some maintenance. Please bare with us, the site will be back up shortly.
Posted
May
02
,
2024
-
16:21
UTC
This incident affected: Nexus Mods Website and API.
×
Subscribe to Incident
Subscribe to updates for
Planned Maintenance
via . You'll receive .