Errors connecting to our infrastructure from certain locations
Incident Report for Nexus Mods
Resolved
We haven't had any reports of this issue for over 24 hours now so we're closing this incident
Posted Nov 17, 2024 - 08:27 UTC
Update
We are still working on this problem - we have identified a number of things that we've changed, but we're still seeing this on-going problem.
Posted Nov 15, 2024 - 18:13 UTC
Update
We're still seeing reports of this problem - our engineers are still investigating and making changes but we currently do not have a fix for this.
Posted Nov 15, 2024 - 08:25 UTC
Update
We are aware that for some users the Nexusmods website becomes unavailable periodically and displays error messages. We are investigating this error. If you are experiencing this problem - users have reported that using a VPN can sometimes resolve this error.
Posted Nov 14, 2024 - 11:44 UTC
Investigating
We are currently investigating this issue.
Posted Nov 14, 2024 - 02:30 UTC
This incident affected: Nexus Mods Website.