Payment provider is unreachable
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Aug
13
,
2025
-
12:30
UTC
Update
Our payment provider is aware of the issue, and their team are currently working on a fix
Posted
Aug
13
,
2025
-
04:33
UTC
Investigating
We're currently unable to create subscriptions because our payment provider is unreachable
Posted
Aug
13
,
2025
-
02:56
UTC
This incident affected: Nexus Mods Website.
×
Subscribe to Incident
Subscribe to updates for
Payment provider is unreachable
via . You'll receive .