Issues on UK2 cluster

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 10:34 UTC

Monitoring

We have routed traffic to UK1 whilst we continue to investigate
Posted Jun 03, 2025 - 20:01 UTC

Investigating

We are currently investigating this issue.
Posted Jun 03, 2025 - 18:47 UTC
This incident affected: Nexus Mods Website.