Incorrect data showing in Mods tab
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Nov
07
,
2024
-
15:02
UTC
Update
-
Posted
Nov
06
,
2024
-
15:10
UTC
Update
-
Posted
Nov
06
,
2024
-
15:07
UTC
Identified
The cause of this fault has now been identified and we're working on a solution.
Posted
Nov
06
,
2024
-
15:02
UTC
Investigating
We have received a number of reports regarding incorrect data showing in the Mods tab on Profile pages.
We are investigating the issue.
Posted
Nov
05
,
2024
-
20:02
UTC
This incident affected: Nexus Mods Website.
×
Subscribe to Incident
Subscribe to updates for
Incorrect data showing in Mods tab
via . You'll receive .