Authentication/ Login Issues
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
May
28
,
2024
-
09:44
UTC
Update
A more permanent fix has now been applied and we are continuing to monitor the situation over the next few days.
Posted
May
23
,
2024
-
14:30
UTC
Update
We are continuing to monitor for any further issues.
Posted
May
23
,
2024
-
03:31
UTC
Monitoring
We have put a temporary fix in place and are continuing to monitor the situation.
Posted
May
23
,
2024
-
03:30
UTC
Update
We are continuing to investigate this issue.
Posted
May
23
,
2024
-
02:15
UTC
Investigating
We are currently investigating an issue where users may be unable to download mods.
Posted
May
23
,
2024
-
02:14
UTC
This incident affected: Nexus Mods Website.
×
Subscribe to Incident
Subscribe to updates for
Authentication/ Login Issues
via . You'll receive .