Site outage
Incident Report for Nexus Mods
Resolved
Our team has identified the issue and a fix is in place.
Posted Feb 03, 2025 - 13:55 UTC
Investigating
We are currently aware of an issue affecting accessing the site. Our team is investigating the issue.
Posted Feb 03, 2025 - 13:35 UTC
This incident affected: Nexus Mods Website and API.