Website connection issues
Incident Report for Nexus Mods
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 08:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2024 - 03:55 UTC
Investigating
We are investigating reports of connection issues to the main website
Posted Sep 05, 2024 - 03:15 UTC
This incident affected: Nexus Mods Website.