Outages

Incident Report for Nexus Mods

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 03:05 UTC

Monitoring

Our hosting partner have reported that they have fixed their network issue

We are restarting a few services on our end that have been affected by the outage and will monitor the situation to ensure things remain stable
Posted Oct 30, 2025 - 02:47 UTC

Identified

One of our hosting providers is having connection failures across their network stack and they are currently investigating.
Until they have resolved these issues, there will be major disruption to nexusmods.com

Our engineers are on hand to ensure that the site comes back up reliably once connectivity is restored

Thank you for your patience
Posted Oct 30, 2025 - 01:57 UTC

Investigating

We are aware of service outages on the site and our engineers are currently investigating
Posted Oct 30, 2025 - 01:28 UTC
This incident affected: Nexus Mods Website and API.