System outage
Incident Report for
Nexus Mods
Resolved
This incident has been resolved.
Posted
Apr
08
,
2024
-
07:38
UTC
Monitoring
Traffic is now reaching our network. Users may notice very slow page response times whilst the following Cloudflare incident is active:
https://www.cloudflarestatus.com/incidents/py7vzccv8pzx
Posted
Apr
07
,
2024
-
15:59
UTC
Identified
There is an active incident at Cloudflare that is preventing traffic from reaching our network
Posted
Apr
07
,
2024
-
15:40
UTC
Update
We are continuing to investigate this issue.
Posted
Apr
07
,
2024
-
15:15
UTC
Investigating
Our website and forums seem to be down at this time. We are aware and investigating the issue.
Posted
Apr
07
,
2024
-
15:14
UTC
This incident affected: Nexus Mods Website and Forum.
×
Subscribe to Incident
Subscribe to updates for
System outage
via . You'll receive .