Activity logs performance degradation
Incident Report for Nexus Mods
Resolved
This incident has been resolved.
Posted May 28, 2024 - 09:56 UTC
Monitoring
We are continuing to monitor the performance
Posted May 28, 2024 - 09:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 22, 2024 - 17:10 UTC
Identified
We are aware of some maintenance work affecting the performance of our activity log system. This is affecting the logs tab on mod pages.
Posted May 22, 2024 - 17:10 UTC
This incident affected: Nexus Mods Website.