We have implemented a fix for the third party scripts causing a degraded browsing experience. We are now monitoring to ensure the issue is resolved.
Posted Mar 15, 2025 - 09:06 UTC
Identified
We have identified an issue loading scripts from a third party CDN and are working on a fix. We are continuing to investigate a degraded experience browsing the site.
Posted Mar 15, 2025 - 08:41 UTC
Investigating
We have reports from some users experiencing slow pages while browsing the site and viewing/downloading mods. We are investigating the issue